Login Issues
Incident Report for Zwift, Inc
Resolved
We're all clear! Thanks for your patience while we fixed the log in issues.
Posted 9 months ago. Dec 20, 2017 - 17:53 UTC
Investigating
We are aware of log in issues, and are currently working to fix them
Posted 9 months ago. Dec 20, 2017 - 17:12 UTC