Problems with events loading
Incident Report for Zwift, Inc
Resolved
This incident has been resolved.
Posted 14 days ago. Oct 06, 2018 - 09:28 UTC
Investigating
We are currently investigating issues with events in-game.
Posted 14 days ago. Oct 06, 2018 - 08:58 UTC
This incident affected: Events.