Issues with login and account creation
Incident Report for Zwift, Inc
Resolved
This incident has been resolved.
Posted Mar 19, 2020 - 20:17 UTC
Monitoring
Our team is monitoring services with login and account creation.
Posted Mar 19, 2020 - 19:10 UTC
Identified
Our team is working to restore service for login and account creation. Thanks for your patience!
Posted Mar 19, 2020 - 18:30 UTC
This incident affected: Zwift Website (Zwift.com) and Log In.