Issue seeing other riders
Incident Report for Zwift, Inc
Resolved
This incident has been resolved.
Posted 26 days ago. Jan 28, 2019 - 03:04 UTC
Investigating
We are currently investigating an issue with seeing other riders in the world. Individual ride ability remains functional.
Posted 26 days ago. Jan 28, 2019 - 02:46 UTC
This incident affected: Ride.