ZwiftPower Live Data Outage
Incident Report for Zwift, Inc
Resolved
This incident has been resolved.
Posted Dec 08, 2020 - 18:36 UTC
Investigating
We're currently experiencing an issue with ZwiftPower, in which data is not uploading to the site automatically.
Posted Dec 08, 2020 - 18:09 UTC
This incident affected: ZwiftPower.