Events are not showing on Zwift.com/events webpage.
Incident Report for Zwift, Inc
Resolved
This incident has been resolved.
Posted Aug 13, 2020 - 15:38 UTC
Update
We are continuing to investigate this issue.
Posted Aug 13, 2020 - 15:09 UTC
Investigating
We are currently investigating this issue. For work around: https://support.zwift.com/events-page-not-display-events-H1teICzzP
Posted Aug 13, 2020 - 15:07 UTC
This incident affected: Events.