Login service is unavailable
Incident Report for Zwift, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Nov 26, 2018 - 21:22 UTC
Investigating
Login service is currently unavailable.
Posted about 2 months ago. Nov 26, 2018 - 21:09 UTC
This incident affected: Log In.