Zwift Shop is down
Incident Report for Zwift, Inc
Resolved
This incident has been resolved.
Posted 8 months ago. Feb 06, 2019 - 22:29 UTC
Investigating
We are currently investigating an issue with the Zwift Shop page.
Posted 8 months ago. Feb 06, 2019 - 21:27 UTC
This incident affected: Zwift Shop.