Delay in Customer Service Response Time
Incident Report for Zwift, Inc
Resolved
This incident has been resolved and our response times should no longer be delayed. Thank you for your patience!
Posted Jul 28, 2023 - 14:16 UTC
Identified
Hello!

Zwift Monitoring has been alerted to an issue with a connected service to our Customer Response time. From our Customer Support Team:

"Our contact management system is experiencing an outage, preventing members from reaching our Community Support team via chat. If you need support during this time, please email us at support@zwift.com.

Thank you for your patience."

Updates to follow
Posted Jul 27, 2023 - 17:19 UTC