Planned maintenance impacting accounts and third-party connections

Scheduled for Apr 15, 03:00 - 06:00 UTC

Update

Planned maintenance on April 15 @ 03:00 UTC will impact user account changes.

See this forum post for details: https://forums.zwift.com/t/planned-maintenance-for-user-accounts-april-14-15/667809
Posted Apr 10, 2026 - 22:57 UTC

Scheduled

Planned maintenance on April 15 @ 03:00 UTC will impact user account changes.

See this forum post for details: https://forums.zwift.com/t/planned-maintenance-for-user-accounts-april-14-15/667809

Zwift is undergoing planned server maintenance April 14 / 15 (depending on your local time zone).

During this window, members will not be able to create an account, change email or password, or connect/disconnect to third party platforms. Please wait to make changes after this maintenance concludes.

When:
April 15 @ 03:00 - 06:00 UTC
April 15 @ 05:00 - 08:00 CEST
April 15 @ 1 - 4 pm Sydney
April 15 @ 12 - 3 am Rio
April 14 @ 11 pm - April 15 @ 2 am US East
April 14 @ 8 - 11 pm US West
Posted Apr 10, 2026 - 20:47 UTC
This scheduled maintenance affects: Account Creation and New Partner Connections.