Zwift Support Pages Temporarily Unavailable
Incident Report for Zwift, Inc
Resolved
The issue preventing our Support Pages from loading has been resolved. Our Support Pages are once again listed as Operational and we will be monitoring the site. Thank you for your patience and understanding.
Posted Nov 08, 2022 - 22:43 UTC
Investigating
There is currently an issue preventing our Support pages from loading on Zwift.com. If you require assistance, you can use the following workaround to contact Zwift Support directly:
* Visit Zwift.com
* Select the "Contact Us" modal at the bottom of the page
Posted Nov 08, 2022 - 22:15 UTC
This incident affected: Zwift Website (Support Page).