Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 25, 2024 - 20:00 UTC
Scheduled
We will perform server maintenance that will briefly prevent logins to Zwift.
Zwifter Impacts: Expect a ~ 1 minute period where logins to the Zwift game app and zwift.com websites will not work. The Zwift Companion app will show an “under maintenance” page.
When: UTC July 25 @ 20:00 -21:30 CEST July 25 @ 10 pm - 11:30 pm Sydney July 26 @ 6:00 am - 7:30 am Tokyo July 26 @ 5:00am - 6:30 am New York July 25 @ 4 pm - 5:30 pm Los Angeles July 25 @ 1 pm - 2:30 pm
Posted Jul 25, 2024 - 17:12 UTC
This scheduled maintenance affected: Zwift Game (Ride, Events, Workouts, Existing Partner Connections (Importing Workouts & Uploading Zwift Activities), Activities, Campaign Progress), Zwift Website (Zwift.com, Support Page, Zwift Shop, Zwift Forums, Activity Feed), and Zwift Companion, ZwiftPower, Log In, Payment Processing, Account Creation.