Issue with Subscription Services
Incident Report for Zwift, Inc
Resolved
The incident has been resolved. If you continue to have issues, please reach out to our customer support team.
Posted Dec 06, 2021 - 18:30 UTC
Investigating
We are currently experiencing an issue with subscription services. We are investigating the issue.
Posted Dec 06, 2021 - 17:50 UTC
This incident affected: Payment Processing.