Zwift monitoring has identified login and gameplay issues and is working to resolve them.
Incident Report for Zwift, Inc
Resolved
This incident has been resolved.
Posted 9 months ago. Feb 18, 2018 - 10:02 UTC
Investigating
Zwift monitoring has identified login and gameplay issues and is working to resolve them.
Posted 9 months ago. Feb 18, 2018 - 08:28 UTC