Zwift.com/Join Unavailable
Incident Report for Zwift, Inc
Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 04:59 UTC
Update
At this time, east coast users may experience issues accessing the membership page: http://my.zwift.com/join. This is an intermittent issue that our team is investigating.
Posted Nov 18, 2020 - 02:16 UTC
Update
Currently, east coast users are experiencing issues accessing the membership pages. This is an intermittent issue, that our team is investigating.
Posted Nov 18, 2020 - 01:18 UTC
Investigating
At this time, certain visitors to Zwift.com/join are not able to access this page. We are currently working on resolving this issue.
Posted Nov 18, 2020 - 01:18 UTC
This incident affected: Zwift Website (Zwift.com).