Forums.Zwift.com is Down
Incident Report for Zwift, Inc
Resolved
This incident has been resolved.
Posted 5 months ago. Apr 07, 2019 - 00:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. Apr 07, 2019 - 00:49 UTC
Investigating
We are currently investigating this issue.
Posted 5 months ago. Apr 07, 2019 - 00:41 UTC
This incident affected: Zwift Forums.