Issues Loading Zwift Events

Incident Report for Zwift

Resolved

This incident has been resolved.
Posted Jul 10, 2026 - 19:16 UTC

Investigating

We are currently investigating reports of slow load times for Zwift events. We appreciate your patience as our team investigates the issue. Updates to follow.
Posted Jun 30, 2026 - 16:20 UTC
This incident affected: Zwift Game (Events).