Direct Debit/SEPA Services impacted
Incident Report for Zwift, Inc
Resolved
Thank you for your patience. This issue is now resolved. If you have questions or things don't yet look correct, please reach out to our Community Support team.
Posted Nov 03, 2023 - 12:33 UTC
Monitoring
The service provider has indicated that this issue is resolved. We will continue to monitor until an all clear is given by the provider. If you need assistance, please reach out to our Community Support team.
Posted Nov 03, 2023 - 12:22 UTC
Identified
Zwift Monitoring has identified an issue with with subscription creation, cancelation and updates. The provider of these systems are actively working on a fix. While these services are impacted, players may see the above actions fail to process.

In the event of a failure, please attempt the action again. We will be monitoring and will update this page as new information becomes available. Thank you for your patience and Ride On!
Posted Nov 03, 2023 - 12:20 UTC
This incident affected: Payment Processing.