Zwift Investigating Delays

Incident Report for Zwift, Inc

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 15:28 UTC

Update

We are continuing to investigate this issue.
Posted Nov 12, 2025 - 15:22 UTC

Update

We are continuing to investigate this issue.
Posted Nov 12, 2025 - 15:19 UTC

Investigating

We are currently investigating reports of users not being able to log in.
Posted Nov 12, 2025 - 15:15 UTC
This incident affected: Zwift Game (Ride) and Log In.