Timeout errors when trying to access ZwiftPower

Incident Report for Zwift

Resolved

After additional backend changes access to ZwiftPower has now been fully restored.
Posted Sep 22, 2026 - 03:43 UTC

Investigating

The issue is reoccurring and we are continuing to investigate the root cause.
Posted Sep 21, 2026 - 23:18 UTC

Monitoring

After implementing some changes on the backend ZwiftPower has been coming back online. We are continuing to investigate the root cause, and are still monitoring.
Posted Sep 21, 2026 - 22:40 UTC

Investigating

At around 14:30 (2:30PM) PT we discovered ZwiftPower was down, and we are currently investigating this issue.
Posted Sep 21, 2026 - 21:43 UTC
This incident affected: ZwiftPower.