All Wahoo, Hammerhead, and Garmin data has been reprocessed. Due to limitations when fetching Garmin data and if Zwifters have only granted Zwift limited permissions to their Garmin account then they may need to disconnect and reconnect their Garmin accounts to pull in any missing historical activities.
Posted Sep 18, 2026 - 16:00 UTC
Update
All Wahoo and Hammerhead data should now be re-processed, and we are continuing to work on re-processing the remaining Garmin data.
Posted Sep 17, 2026 - 21:33 UTC
Update
All Wahoo data should now be re-processed, and we are working on re-processing Garmin and Hammerhead data next.
Posted Sep 17, 2026 - 18:02 UTC
Monitoring
Starting from ~2:30PM PT on September 15th to ~6:30AM PT on September 16th we detected an outage impacting the ingestion of activity data from Garmin, Hammerhead, Wahoo, and Whoop. We are currently re-processing activities from this time frame for all impacted Zwifters.
Posted Sep 17, 2026 - 16:18 UTC
This incident affected: Zwift Game (Existing Partner Connections (Importing Workouts & Uploading Zwift Activities)).