Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 26, 2026 - 04:30 UTC
Scheduled
Zwift will be performing planned maintenance on our subscription systems July 26, 2026, 04:30 AM UTC and is expected to last about 5 hours. Use this site to convert to your local time zone.
During this 5-hour maintenance window, there will be a brief period (approximately 5 minutes) when creating new subscriptions or making changes to existing subscriptions will not be available.
Current Subscribers - You will be able to log in and use Zwift as usual. - Changes to your subscription (such as updating your payment method, changing plans, or canceling) will not be available during the brief 5-minute window.
New Subscribers - Creating a new subscription may not be available during the brief maintenance window.
If you encounter an issue, please wait until the maintenance has concluded and try again.
Posted Jul 23, 2026 - 16:12 UTC
This scheduled maintenance affected: Payment Processing and Account Creation.