Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 02, 2024 - 14:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 01, 2024 - 20:06 UTC
Scheduled
We will be performing maintenance impacting race results. We expect a 5 minute window during the maintenance period where Zwifters might not see their race results upload immediately in The Game, Zwift Companion, ZwiftPower, or Zwift.com's Activity Feed. After the maintenance is completed, the results will appear after a short delay.
When: UTC: October 2 @ 14:00 - 14:30 CET: October 2 @ 4:00 -4:30 pm Sydney: October 3 @ 00:00 - 00:30 am Tokyo October 2 @ 11:00 - 11:30 pm Rio: October 2 @ 11:-00 - 11:30 am New York Ocrtber 2 @ 10:00 - 10:30 am Los Angeles October 2 @ 7:00 - 7:30 am
Use this website to convert to your local time zone.
Posted Oct 01, 2024 - 16:25 UTC
This scheduled maintenance affected: Zwift Game (Events, Activities), Zwift Companion, ZwiftPower, and Zwift Website (Activity Feed).